Corrigindo a atualização do Pacman para versão 4.0.1 no ArchLinux

 [quote]Pessoal, hoje fui atualizar o sistema do meu Archlinux e dei de cara com essa mensagem:[/quote]

:: Sincronizando a base de dados de pacotes…
core está atualizado
extra está atualizado
community está atualizado
archlinuxfr está atualizado
:: Os seguintes pacotes precisam ser atualizados antes :
pacman
:: Você deseja cancelar a operação atual
:: e atualizar estes pacotes agora? [S/n]
resolvendo dependências…
procurando por conflitos interrelacionados…
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: packagekit: requer pacman < 3.6.0
:: package-query: requer pacman < 3.6
:: pacman-color: requer pacman < 3.6

O problema foi resolvido removendo o yaourt, packagekit, package-query e pacman-color. Caso você não tenha alguns dos pacotes acima desinstale apenas o que você possui. Se você não tiver o pacman-color por exemplo não inclua ele.

Depois atualizando com o comando:

Quando perguntando sobre atualizar antes o Pacman eu respondi com Não.

Atualize a lista de pacotes normalmente e o Pacman será também instalado.
Confira agora a versão do pacman:

Agora precisamos ativar as chaves GPG no nosso Pacman, que será padrão daqui para frente.
Isso pode demorar um pouquinho, então aguarde que é normal:

Agora renomeie o pacman.conf para o que foi atualizado junto da nova versão do Pacman:

Instalando o Yaourt

Se você possui o YAOURT instalado no seu Archlinux, você vai sentir falta com certeza!
Lembra que desinstalamos ele? então vamos instalá-lo novamente.

Para efetuar a instalação do yaourt é necessário inserir um novo repositório no seu Arch Linux. Edite o novo arquivo atualizado /etc/pacman.conf com o seguinte comando:

Adicione as seguintes linhas no final do arquivo:

Depois disso é só instalar os seguintes pacotes:

Os outros programas desinstalados na atualização você também pode instalá-los novamente.

Pronto! Agora o yaourt está pronto para ser utilizado e seu Pacman atualizado!

Author Description

dodilei

Dizem que falo comendo as palavras, mas o que gosto de comer é um bom paniqueijo! além de OpenSource, Linux, Python e Javascript! :D

Nenhum comentário ainda.

Join the Conversation